股票课程网

选股小技能

Class:公式教程 Time:2017-7-26 Hits:1776

1,30个交易日内,股价跌幅达到一半的股票:

xg:(hhv(c,30)-c)/hhv(c,30)>0.5;

2,今天的量  是5天平均的 2倍以上  

xg:v>ma(v,5)*2;

缩量

vol/ma(vol,10)<0.3;

3,两天内,累计下跌等于或超过20%选股.

xg:(ref(c,2)-c)/c>0.2;

4,股价是25天以来新低.

xg:c<ref(llv(c,25),1);

5,选股:EXPMA 5日与10日金叉 并且第二天的收盘价在EXPMA的5日线以上.

cross(ref(ema(c,5),1),ref(ema(c,10),1)) and c>ema(c,5);

6,请编买入公式:

1. 将BIAS指标的参数设置为24日,将KD指标的参数设置为9;3;3。

2. BIAS指标要小于-6,这只是确认该股超跌的初选条件。

3. KD指标产生黄金交叉,K线上穿D线。

4. KD交叉同时,KD指标中的D值要小于16。

BIAS3 :=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100,colorff00ff;

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1),COLORWHITE;

D:=SMA(K,3,1),COLORYELLOW;

xg:BIAS3<-6 and cross(k,d) and d<16;

7,要求是量大、换手率达到3左右,涨幅>7个点。

xg:v/capital*100>3 and (c/ref(c,1)>1.07;

8,个股分时图上都有一条黄线,叫做均价线

a/capital*100;

9,"阴转阳"的公式(也就是昨天收阴线,今天收阳线)

xg:ref(c,1)<ref(o,1) and c>o;

10,股价回抽20日均线选股公式

xg:ref(c,1)>ma(c,20) and cross(ma(c,20),c);

11,一根大阳线,至少有5个点以上,再连着出现二根振幅不大于5的十字星或是小K线

xg:(ref(c,3)-ref(c,4))/ref(c,3)>0.05 and count((h-l)/l<0.05,2)=2;

12,行情信息里的&ldquo;涨幅&rdquo;的原码

(c-ref(c,1))/c*100;

13,kdj的J从上向下穿越O轴发出信号

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1),COLORWHITE;

D:=SMA(K,3,1),COLORYELLOW;

J:=3*K-2*D,COLORFF00FF;

xg:cross(0,j);

14,股价4天中有两天在10日线上

count(c>ma(c,10),4)=2;

15,选出10天内出现了涨停的个股

count(c/ref(c,1)>1.1,10)>0;

又:

今涨停:=C/REF(C,1)>1.09;

选股:count(今涨停,n);

16,一阳上穿10,20,30日线,量能是前一天3倍。

xg:cross(c,ma(c,10)) and cross(c,ma(c,20)) and cross(c,ma(c,30)) and v>ref(v,1)*3;

17,共三根K线,第一根K线为阴线;第二根K线为阴线线,最高价低于第一根K线,最低价高于第一根K线;第三根K线阴阳不限,最高价低于第二根K线,最低价高于第二根K线。满足后发出信号~

w1:=ref(c,2)<ref(o,2);

w2:=ref(h,2)>ref(h,1) and ref(l,2)<ref(l,1);

w3:=ref(h,1)>h and ref(l,1)<l;

xg:w1 and w2 and w3;

18, 选出今日成交量大于昨日成交量一成的股票。

xg:v>ref(v,1)*1.1;

19, 连续5天,当日的5日均线减前一天的5日均线差值小于1.

count((ma(c,5)-ref(ma(c,5),1))<1,5)=5;

20,股价上穿5周均线:

xg:cross(c,ma(c,5));

注意:选股时用周线

21,上穿30日均线的公式

xg:cross(c,ma(c,30));

22,两笔阴线中间夹着一根阳线或数根K线,其中两笔阴线最低点相等

xg:ref(l,2)=l;

23,量比大于1 同时换手大于2的公式

xg:v/ref(v,1)>1 and AMOUNT/CAPITAL*100>2;

24,换手:VOL*100/CAPITAL;

周期换手:SUM(换手,10);

25,流通盘小于4000万 的选股公式

xg:CAPITAL/100<4000;

26,涨停开盘跌停收盘选股

xg:h/ref(c,1)>1.1 and ref(c,1)/l>1.1;

27,当天开盘价与收盘价相等的选股公式

xg:c=o;

28,5日均线向上 流通盘小于5000万 换手率大于3的选股公式

lt:CAPITAL/100<5000;

换手:=VOL*100/CAPITAL<3;

w1:ma(c,5)>ref(ma(c,5),1);

xg:lt and 换手 and w1;

29,收下影线

xg:c>l;

光头阳线:

V/REF(MA(V,5),1)>2.5 AND C>O AND C=H;

30, o=l就没有下引线了,那就:

xg:c>l and o>l;

31,当日收盘下穿5日均价

xg:cross(ma(c,5),c);

32,最低价小于前一日的最低价但收盘后为阳线。

xg:l<ref(l,1) and c>o;

33,30日内到本日收盘价下跌20%的公式

xg:hhv(c,30)/c>1.2;

34,选周线跳空缺口的个股。

xg:HIGH<REF(LOW,1) OR

LOW>REF(HIGH,1);

周期选周线

35,30日均线走平或走高的个股

xg:ma(c,30)>ref(ma(c,30),1);

36,连续4天的收盘价格波动幅度在3%之内连续走平或向上

count(abs(c-ref(c,1)/ref(c,1))<0.03 and c>ref(c,1),3)=3;

37,下影线长于上影线

(c-l)>(h-c);

38, 收盘价+收盘价的10%

(c+c*0.1);

39,今天高开的公式

c>o;

40,今天的量大于等于昨天量的2倍,股价上涨

xg:v>ref(v,1)*2 and c>ref(c,1);

41,今天的量小于昨天量的2倍以上,股价上涨

xg:v<ref(v,1)*2 and c>ref(c,1);

42,大部分股票跌到43日均线时就会反弹,如果在43日均线附近买入,短线成功率占90%以上,即时选出还差几分钱就跌到43日均线的股票。

xg:abs(c-ma(c,43))/ma(c,43)<0.01;

43,{选出每天换手5%-15%之间的股票}

Var1:=100*VOL/CAPITAL;

w1:=var1>5;

w2:=var1<15;

xg:w1 and w2;

44,换手率10天80%以上的选股公式

sum(VOL/CAPITAL*100,10)>80;

45,60个交易日内,涨幅大于9.9%(涨停)的天数

count(c/ref(c,1)>1.099,60);

46,昨天跌幅大于3%,今天开盘高开2%以上的选股公式。

xg:ref(c,1)/ref(c,2)<0.97 and o/ref(c,1)>1.02;

47,选出周换手率小于10%的股票

sum(VOL/CAPITAL*100,5)<10;

48,成交量创20日新低,并且股价也创20日新低

xg:v=llv(v,20) and c=llv(c,20);

49,5日不涨,绿线收盘选票指标

count(c<o,5)=5;

50,"今日MACD等于昨天的MACD  ,且macd>0"  的指标

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

xg:macd=ref(macd,1) and macd>0

51,连续2天收盘价跌破30日均线,就显示"卖出"信号

a1:count(c<ma(c,30),2)=2;

drawtext(a1,c,'卖出'),colorgreen;

52,股票在这条均线上在8天以上,上下幅度不大,

a1:abs((c-ma(c,120))/ma(c,120))<0.1;

xg:count(a1,8)=8;

53, 连续三天高开高走的选股公式

count(o>ref(c,1) and c>o,3)=3;

54,n天内曾经有m个涨停

count(c/ref(c,1)>1.09,n)>m;

55,股价比昨天的高,量比昨天小,放量。

xg:c>ref(c,1) and v<ref(v,1) and ref(v,1)>ref(v,2)*2;

56,连续3天每天的最低价都比前一天高

count(l>ref(c,1),3)=3;

57,周量缩小50%或40%或n%

a1:vol/capital*100;

xg:a1/ref(a1,1)<n/100;

58,股价超过五日均价的15%以上,并给出卖出信号

卖出:c/ma(c,5)>1.15;

59,连收两个十字星的选股公式

count(abs((c-o)/o<0.01),2)=2;

60,n横盘天数,n1横盘的上下幅度

REF(((HHV(H,N)-LLV(L,N))/LLV(L,N)),1)<=(n1/100)

and ref(v,1)<ref(ma(v,5),1) and cross(v,ma(v,5)) and cross(v,ma(v,10));

61,收盘价连续8天都站在5日均线的股票。

count(c>ma(c,5),8)=8;

62,振幅大于5%,收盘价大于3.5小于15元,三日均线大于昨日的三日均线,去掉ST股。

a1:=h/l>1.05;

a2:=c>3.5 and c<15;

a3:=ma(c,3)>ref(ma(c,3),1);

xg:a1 and a2 and a3;

63,收盘价下有60天前的远期获利盘n%。

{60天前的远期获利盘:=ppart(60)*100;}

aa:WINNER(ref(c,60 ))*100;

64,连续三日收阳 后日收盘高于前日 且每日收于当日最高价附近 每日涨幅不大于4%

选股:count(c>o and c>ref(c,1) and abs((h-c)/c)<0.01 and c/ref(c,1)<1.04,3)=3;

65,昨日收阴, 今日收阳,的K线组合。

C>O AND REF(C,1)<REF(O,1);

66,股价突破5ma买入,跌破5ma卖出。买入和卖出用箭头表示 (副图)

a1:cross(c,ma(c,5));

a2:cross(ma(c,5),c);

drawtext(a1,low*0.98,'&uarr;'),colorred;

drawtext(a2,h*1.02,'&uarr;'),color00ffff;

67,今天的250平均线大于昨天的昨天的250平均线

ma(c,250)>ref(ma(c,250),1);

68,历史高点到前一高点画线

POLYLINE(h>=hhv(c,0),h);

69,均线中增加一根线,这根线的价格是5日线的1.2倍

aa:ma(c,5)*1.2;

70,20天均线向上的股

xg:ma(c,20)>ref(ma(c,20),1);

71,连续3天收盘全是阴线。

count(c<ref(c,1),3)=3;

72,今天收盘价在昨天收盘价-2%~2%之间

c/ref(c,1)>0.98 and c/ref(c,1)<1.02;

73,收盘价在5日均线以上5天

count(c>ma(c,5),5)=5;

74,N天前换手率大于8%  

REF(VOL/CAPITAL*100,N)>8;

75,一条均线18MA  股价上涨后&ldquo;缩量&rdquo;回调到18MA

XG:COUNT(V<REF(V,1) AND C<O,N)=N AND C>MA(C,18);

N  &ldquo;缩量&rdquo;回调的天数

76,1。昨日量是n天以来最低量,(n可调);2。今日量是昨日量的m倍,(m可调);3。今日k线收阳线;

xg:ref(v,1)=llv(ref(v,1),n) and v>ref(v,1)*m and c>o;

77,第一天收阴,第二天,第三天,第四天,收出红三兵

XG:REF(C,3)<REF(C,4) AND COUNT(C>O,3)=3;

78,月k线十字星收盘  并且5月线拐点向上。

XG:ABS(C-O)/O<0.02 AND MA(C,5)>REF(MA(C,5),1);

用月线选股

79,最近3天(包括昨天.前天)股价突破250日均线

COUNT(C>MA(C,250),3)=3;

80,跳高大阴线,条件: 1 开盘跳空4%以上2 大阴线实体6%以上.

O/REF(C,1)>1.04 AND C/REF(C,1)<0.94;

81,条件:1: 假设大前天创最近新高,要求这天涨幅是超过7%的大阳线,且创最近一个月的新高.

2: 那么前天,昨天,今天都收小K线,要求小K线实体

xg:ref(c,3)/ref(c,4)>1.07 and ref(c,3)=hhv(c,20) and count(abs((c-ref(c,1))/ref(c,1)<0.02,3)))=3;

82,60与120均线距离在n%内

XG:ABS((MA(C,60)-MA(C,120))/MA(C,120))<N/100;

83,5日均线倾角大于60度

X:(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.1415926)>60;

也可以这样:

X:(ATAN((EMA(C,5)/REF(EMA(C,5),1)-1)*100)*180/3.1415926)>60; 利用指标排序:X:(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.1415926);  84,&ldquo;中阴之后,跳拉阳&rdquo;c/ref(c,1)>1.05;

85,count(x,n) 意思是n天内出现过信号的,假设n=10,那么就是10天内出现信号(包括今天),如果不加这个的话,就是限定在今天出信号才选出来,以前的不管。

86, 今天涨停的公式C/REF(C,1)>1.09;

87,10日内有涨停的公式今涨停:=C/REF(C,1)>1.09;

选股:count(今涨停,10);  88,昨日前日涨停的REF(C,1)/REF(C,2)>1.095;   89,近5日K线最高价和最低价格波动在10%以内,成交量是昨日2倍,收盘涨5%

XG:(HHV(C,5)-LLV(C,5))/LLV(C,5)<0.1 AND V>REF(V,1)*2 AND C/REF(C,1)>1.05;  90,60与120均线距离在n%内XG:ABS((MA(C,60)-MA(C,120))/MA(C,120))<N/100;   91,&ldquo;中阴之后,跳拉阳&rdquo;c/ref(c,1)>1.05;   92,能在图上提示个股(不含S或ST股)出现过的涨跌停板日期的公式

w1:if((c-ref(c,1))/ref(c,1)>0.1,date-1000000,c);   93,涨幅&le;2% (c-ref(c,1)/ref(c,1)*100<2;   94,5日,10日,30日贴近公式,越贴越好m1:=ma(close,5);

m2:=ma(close,10);

m3:=ma(close,20);

m4:=ma(close,30);

y1:=max(max(max(m1,m2),m3),m4);

x1:=min(min(min(m1,m2),m3),m4);

黏合:y1/x1<n;

n越小越黏合(n,1.01-----1.05)  95,(1)换手率均线DMA(c ,v/CAPITAL );

(2)20天以来的任意天期(n),换手率均线正负波动值<=p%;

AA:=DMA(c ,v/CAPITAL );

ab:=(aa-ref(aa,1))/ref(aa,1)*100<p;

bb:count(ab,20)>=n;

96, 30天线拐头向上出现提示

ma(c,30)>ref(ma(c,30),1);

97,今天的换手率大于前天的一倍以上

w1:=v*100/capital;

w1>ref(w1,2)*2;

98,K线沿着5日均线往上爬的选股公式 w1:ma(c,5);

w2:abc(c-w1)/w1<0.01;

xg:count(w1>ref(w1,1),5)=5 and w2;  99,20日均线,上穿62日均线 xg:cross(ma(c,20),ma(c,62));   100,平台整理的公式,整理时间和整理幅度可调

COUNT(CLOSE,0)>N AND

(HHV(CLOSE,N)-LLV(CLOSE,N))/LLV(CLOSE,N)<=(N1/100);

N整理时间,N1整理幅度   101,选出当日收盘价突破10日均线5%的个股

cross(c,ma(c,10)*1.05);  102,选出当日最低价在10日均线上下0.05%内,收盘价在均线上方的个股

abs(l-ma(c,10))<0.005 and c>ma(c,10);  103,第一天股票涨停,第二天成交量是第一天成交量的1倍,并超过10%.那第三天就是买点

w1:=ref(c,2)/ref(c,3)>1.1;

w2:=ref(v,1)/ref(v,2)>2;

xg:w1 and w2;

104,放量2倍突破300日线的选股指标

cross(c,ma(c,300)) and v>ref(v,1)*2;

105,3日均线上穿10日均线,KDJ有效金叉

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

w1:=cross(ma(c,3),ma(c,10));

xg:w1 and cross(k,d);   106,30日均线拐头向上 ma(c,30)>ref(ma(c,30),1);

107,连续3-5天,每天的收盘价涨跌幅不超过1%. w1:abs(c-o)<0.01;

xg:count(w1,5)>=3;

108,K线收十字星 abs(c-o)/o<0.01;

109,MACD在8天以内两次金叉DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));

DEA:=EMA(DIFF,9),COLORBLUE,LINETHICK0;

MACD:=2*(DIFF-DEA);

w1:cross(DIFF,dea);

xg:count(w1,8)>=2;

110,昨天升降幅在-n%----n%之间

w1:abs(ref(c,1)-ref(c,2))/ref(c,2)*100<n;  111,于20日均线相差2个百分点的

w1:abs(c-ma(c,20)/ma(c,20)*100<2;

N日均线相差M个百分点的公式.

w1:abs(c-ma(c,n)/ma(c,n)*100<m;

n:N日 m:M个百分点   112,60MA由向下调头向上 ma(c,60)>ref(ma(c,60),1);

113, 股价回调到14日均线的选股 abs(c-ma(c,14))/ma(c,14)<0.005;

114,历史第5根K线到第30根K线之间的最高价hhv(ref(c,5),25);

115,MACD的拐点公式DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));

DEA:=EMA(DIFF,9),COLORBLUE,LINETHICK0;

MACD:=2*(DIFF-DEA);

拐点:ref(macd,2)>ref(macd,1) and ref(macd,1)<macd;

116,跳空高开收阳线LOW>REF(HIGH,1) and c>o;  117,涨停过300日线的选股公式

c/ref(c,1)>1.09 and cross(c,ma(c,300));   118,成交量是前5天中其他任何一天的10天均量线的3.5倍以上

w1:=llv(ma(v,10),5);

xg:v>w1*3.5;

119,股价N天内连续沿着5天线走,且每天收盘价与5天线的距离不超过2%的选股公式

w1:=abs(c-ma(c,5))/ma(c,5)<0.02;

xg:count(w1,n)=n;

120,跳空高开后,三天内没有回补缺口

ref(LOW,2)>REF(HIGH,3) and l>ref(LOW,2);  121,日涨幅小于3%C>0    AND    C/REF(C,1)  >1.03;

122, 股价创30个交易日的新高H>ref(H,30);

123,连续n天收阳线UP:=CLOSE>OPEN;

COUNT(UP,N)=N; 124, {5日内第二大量}

zdl:=hhv(v,5);

v0:=IF(v>=zdl,0,v);

v1:=IF(ref(v,1)>=zdl,0,ref(v,1));

v2:=IF(ref(v,2)>=zdl,0,ref(v,2));

v3:=IF(ref(v,3)>=zdl,0,ref(v,3));

v4:=IF(ref(v,4)>=zdl,0,ref(v,4));

第二大量:MAX(MAX(MAX(MAX(v0,v1),v2),v3),v4);

DRAWTEXTABS( 0,10 ,'第一大量 '+ zdl+'  第二大量'+第二大量);  同理可求出第三大、第四大和最小量.实行简单的排列.

这个公式好比是一件完整产品中的一个零部件,解决了一个思路问题.   125,{5日均线倾角大于60度}

X:(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926)>60;  126,连续三涨停A:=C/REF(C,1)>1.095;

XG:EVERY(A,3);   127,30日线开始上翘

MA30:MA(C,30);

(MA30>REF(MA30,1)) AND (REF(MA30,1)<=REF(MA30,2));  128,当收盘价大于10均线时,主图背景是黄色的,小于的时候是绿色的ma10:=ma(c,10);

DRAWGBK(c>=ma10),colorred;

DRAWGBK(c<ma10),colorgreen;  129,日涨幅小于3%C>0  AND  C/REF(C,1)  >1.03;  130,股价创30个交易日的新高H>ref(H,30)  131,3根阳线,并且第二根阳线的量比第一根小,第三根的量比第二根小EY:=CLOSE>OPEN;

ZL:=VOL<REF(VOL,1);

XG:SUM(EY,3)=3 AND SUM(ZL,3)=3;

或者这样:

EY:=CLOSE>OPEN;

ZL:=VOL<REF(VOL,1);

XG:COUNT(EY,3)=3 AND COUNT(ZL,3)=3;

132,昨天的量为阴量,或昨天量比前天量要小(缩量)SL:REF(VOL,1)<REF(VOL,2) AND REF(CLOSE,1)<REF(OPEN,1);

133,只要交换金叉时均线前后的位置,就变成死叉的写法了:

死叉:CROSS(MA(C,10),MA(C,5));  134,macd后金叉高于前金叉:

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

JC:=CROSS(DIFF,DEA)AND DEA<0;

JJ:=BARSLAST(JC);

QC:=CROSS(DIFF,DEA)AND COUNT(JC,30)=2;

REF(DEA>REF(DEA,JJ),1)AND QC;

REF(DEA<REF(DEA,JJ),1) AND QC;

135,计算N日均线斜率:

JX:=REF(EMA(C,N),1);

斜率:(EMA(C,N)-JX)/JX*100;

136,开盘N小时内,股价一直大于均价:

IF(OPENMINUTES(HOUR<N),C>DYNAINFO(11),0);

137,N天内跌幅超过X:

N:=20;X:=30;

IF(SUM((1-C/REF(C,1))*100,N)>X,1,0);

138,macd二次金叉:

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

JC:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));//首先界定金叉条件:

选股:CROSS(DIFF,DEA) AND DEA<0 AND JC=2; //定位金叉的次数:

139,M天内、曾经N次涨停:

连续涨停:=COUNT(C/REF(C,1)>1.099,N)=N;

所有个股:COUNT(连续涨停,M)=1;

140,N天内跌幅超过X:

N:=20;X:=30;

IF(SUM((1-C/REF(C,1))*100,N)>X,1,0); 141,2阳夹1阴REF(C,2)>REF(O,2) AND REF(C,1)<REF(O,1) AND

C>O AND C>=REF(O,1); 142,昨天大涨今收阴十字星大于昨收盘:昨天大涨:=REF(C,1)/REF(C,2)>1.05;

阴十字星:=H/L>1.015 AND O>C AND H>O AND C>L AND O/C<1.005;

大于昨收盘:=C>REF(C,1);

选股:昨天大涨 AND 阴十字星 AND 大于昨收盘;

143,全天涨停:全天涨停:(LOW>REF(HIGH,1)) AND (HIGH=LOW);

144,跳空高开的选股公式

o>ref(h,1);

145,{靠近年线}

a1:(c-ma(c,250))/ma(c,250);

0;  146,10日内的K线实体的幅度(不管是阴是阳)全部小于3%的选股公式:

选:count((abs(c-o)/min(c,o)*100)<3,10)=10;

{www.gwgz.net 股票教程网_最新股票指标公式}

147,公式条件:

1.换手率大于3%;

2.量比大于2倍;

3.现价小于10元;

4.流通盘小于2亿股;

5.每股收益大于0.1元;

6.涨幅大于3%;

7.MACD的DIFF上穿DEA,金叉;

X1:=DYNAINFO(37)>0.03;

X2:=DYNAINFO(17)>2;

X3:=C<10;

X4:=CAPITAL/1000000<2;

X5:=FINANCE(33)>0.1;

X6:=(C-REF(C,1))/REF(C,1)>0.03;

X7:=CROSS(MACD.DIF,MACD.DEA);

XG:X1 AND X2 AND X3 AND X4 AND X5 AND X6 AND X7;

148,股价涨停.在K线图上画黄色STICKLINE(C/REF(C,1)>=1.099,O,C,1,0),COLORYELLOW;

149,今收盘对于N日内最低收盘价的涨幅(%)



(C-LLV(C,N))/LLV(C,N)*100;



150,今收盘对于N日内最高收盘价的跌幅(%)



(HHV(C,N)-C)/HHV(C,N)*100;



151,股价在过去N日内运行空间的相对位置



(C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100;



152,股价上方N1%至N2%处的筹码(%)



AA:=WINNER(C+C*N2/100)*100;

BB:=WINNER(C+C*N1/100)*100;

AA-BB



153,股价下方N1%至N2%处的筹码(%)



(WINNER(C-C*N1/100)-WINNER(C-C*N2/100))*100;



154,收盘价N%处的套牢盘



100-(WINNER(C*N/100))*100;

155,收盘价N%处的获利盘



WINNER(C*N/100)*100;

156下影线



(MIN(C,O)-L)/(H-L);

157,上影线



(H-MAX(C,O))/(H-L)

158,本周期的涨跌幅



(C-REF(C,1))/REF(C,1)*100;

159,振幅



(H-L)/L*100;

160,均线金叉



CROSS(MA(C,N),MA(C,M));{N< M}



161,均线死叉



CROSS(MA(C,M),MA(C,N));{N< M}

162,均线多头排列



A1:=MA(C,N1);

A2:=MA(C,N2);

A3:=MA(C,N3);

A4:=MA(C,N4);

COUNT(A1>A2 AND A2>A3 AND A3>A4,3);



163,均线空头排列

A1:=MA(C,N1);

A2:=MA(C,N2);

A3:=MA(C,N3);

A4:=MA(C,N4);

COUNT(A1< A2 AND A2< A3 AND A3< A4,3);

164,N日均线向下



AA:=MA(C,N);

BB:=REF(AA,1);

AA< BB

165,N日均线向上



AA:=MA(C,N);

BB:=REF(AA,1);

AA>BB

166,N日均线走平



AA:=MA(C,N);

BB:=REF(AA,1);

AA=BB

167,向前N日至M日出现过均线死叉(P1< P2)



AA:=MA(C,P1);

BB:=MA(C,P2);

CC:=REF(CROSS(BB,AA),N);

COUNT(CC,M);

168,今日成交量大于N日以来的均量



VOL>MA(VOL,N);

169,低位密集



A1:=COST(85);

A2:=COST(15);

A3:=A1-A2;

A4:=(A1+A2)/2;

A5:=A3/A4*100<10;

B1:=HHV(H,120);

B2:=LLV(L,120);

B3:=B1-B2;

B4:=(A4-B2)< B3/2;

A5 AND B4;

170,换手率



VOL/CAPITAL*100;

171,N日盈亏



V1:=VOL/SUM(VOL,N);

V2:=DMA(CLOSE,V1);

V3:(CLOSE-V2)/V2*100;

172,均线粘合:

设均线为a1,a2,a3

ff:=max(max(a1,a2),a3);

bb:=min(min(a1,a2),a3);

zz:=(ff/bb-1)*100<1;

count(zz,3)=3;

173,连续3涨停

COUNT(c/ref(c,1)>1.094 ,4)=4;  174,大智慧公式短语1间隔点:

20,colorred,pointdot,linethick2;

80,colorred,pointdot,linethick2;

50,colorred,pointdot,linethick2;

2间隔线

20,colorred,linethick2;

80,colorred,linethick2;

50,colorred,linethick2;

3信号字

DRAWTEXT(RSI1<10,RSI1,'买'),Colorlime;

DRAWTEXT(RSI1>85,RSI1,'卖'),Colorlime;

4笑哭脸

DRAWICON(VR24<25,VR24,1),ColorFF0000;

DRAWICON(VR24>350,VR24,2),ColorFF0000;

5一线提示

cross("kdj.j"(9,3,3),"kdj.d"(9,3,3)) and "kdj.j"(9,3,3)<20,colorred

6一柱顶天

IF(VAR4=50,50,0),stick,linethick2;

7小人作怪

多头卒:Var3,LINETHICK2, COLORf00ff0;

空头卒:Var4,LINETHICK2, COLORYELLOW;

DRAWICON(Var9,Var9,1);

DRAWICON(Var10,Var10,2);

8小人

买入:Var1 AND Var2,stick,linethick2,colorred;

卖出:CROSS(80,Var4),stick,linethick2,colorgreen;

drawicon(卖出,1.1,2);

drawicon(买入,1.1,1);

175,大智慧开立方POW(X,1/3);  176,副图里K线写法:

STICKLINE(C>=O,C,O,8,1),COLORff00ff;

STICKLINE(C>=O,O,L,0.1,0),COLORff00ff;

STICKLINE(C>=O,C,H,0.1,0),COLORff00ff;

STICKLINE(C<=O,C,O,8,0),COLOR007d00;

STICKLINE(C<=O,H,O,0.1,0),COLOR007d00;

STICKLINE(C<=O,C,L,0.1,0),COLOR007d00;  177,几天前均线金叉ref(CROSS(MA(C,5),MA(C,10)),n);  178,N日首次涨停

input:n(60,30,100);

A:=COUNT(REF(C,1)*1.1-C<0.005,N)>0;

A AND SUM(A,N)=1;

179,每笔大于20万元的主动买单和主动卖单的成交笔数

主动买:=if(BUYVOL>0,AMOUNT/10000,0);

主动卖:=if(SELLVOL>0,AMOUNT/10000,0);

买:sum(主动买>20,0);

卖:sum(主动卖>20,0);

180,早盘量满:CROSS(VOL,REF(VOL,1)) AND FROMOPEN<30 ; (通达信用)

指标解释:CROSS(VOL,REF(VOL,1))--就是今天的成交量超过昨天成交量;

FROMOPEN<30 --就是开盘后30分内有效,那么我们可以根据自己的需要进行改进。

比如可以设在10:00点钟开始预警,到10:30分结束,那么就写成FROMOPEN>30  and  FROMOPEN<60.

181,长期盘整大于n天:(HHV(CLOSE,n)-LLV(CLOSE,n))/REF(C,1)*100<25;

182,120天内涨停次数:ZF:=(c-ref(c,1))/ref(c,1)*100;

次数:count(ZF>9,120);

183,近3天成交量比3天前缩量一半以上(n=3):

a:=sum(v,n);

a<ref(a,n)/2; 184,去ST,和限制涨停股.

ST:=STRFIND(stkname,'ST',1)>0;

S:=STRFIND(stkname,'S',1)>0;

and (c-ref(c,1))/ref(c,1)<0.096 AND not(ST)   and not(S);

185,跌5天后,股价不创新低:

AA:COUNT((C<O),5)=5 AND L>REF(L,1);

186,板后n日内涨幅:

zt:=C/REF(C,1)>1.098;

gl:=FILTER(zt,n);

ts:=ref(L,BARSLAST(gl));

ZF:(ANY(ZT,n))*(c-ts)/ts*100;

187,当日获利比例:

获利比例:100*WINNER(c);

188,5日涨幅在10%-20%:

五日涨幅:=(C-REF(C,4))/REF(C,4)*100;

XG:五日涨幅>=10 AND 五日涨幅<=20;

189,低开收大阳、低开收大阴:

{01-低开收大阳}

qj1:O<ref(l,1) and (C/REF(C,1)-1)*100>6;

{02-低开收大阴}

qj2:O<ref(l,1) and (C/REF(C,1)-1)*100<-5.1;

190,求两个价位之间的最大值、和最小值:

最大值:MAX(CLOSE,REF(CLOSE,N));

最小值:MIN(CLOSE,REF(CLOSE,N));

191,四连阳怎样写?

四连阳:C>O and COUNT(C>REF(C,1),4)=4;

192无量创新高:

vol/capital<0.02 and h>=hhv(high,20) and close>open;

193,指定日期的收盘价:

IF(DATE>1070530,CLOSE,0);

这是去年5月30日的收盘价,时间你可以自己调整。

194,历史内外盘:外盘:vol-DYNAINFO(22);

内盘:vol-DYNAINFO(23);

195,在20天内,出现ma5二次上穿ma10:

INPUT:N(20),N1(5,1,300),N2(10,5,900);

M1:=MA(C,N1);

M2:=MA(C,N2);

TJ:COUNT(CROSS(M1,M2),N)>1;

196,返回以前值分时界面下:

REF(C,BARSLAST(TIME=095500));日线界面下:

REF(C,BARSLAST(DATE=1101221));

197,涨停又打开预警:

H/REF(C,1)>1.098 AND C<H;

198,macd上穿0:

CROSS("MACD.MACD",0);

199,涨停回调:

input:N(10,1,300,1);

A:=between(close/ref(close,1),1.0975,1.105);

涨停回调:dynainfo(8)>0 and strfind(stkname,'S',1)=0 and

(ref(count(A,10),1))>=1 and

{10日内出现过一个涨停板}

{between(c,"ma.ma1","ma.ma2") and }

"ma.ma1">"ma.ma2" and "ma.ma2">"ma.ma3" and "ma.ma3">"ma.ma4" and

{短期均线呈多头排列,但当日收盘价在5日10日均线之间}

v<ref(v,1) and ref(v,1)<ref(v,2);

{成交量连续3天递减}

200,3天量递增:

A:=VOL>REF(VOL,1);

COUNT(A,3)=3; 

{股票课程网,http://gpkcw.net,友情提供}
股票教程网所有股票公式,仅供学习研究,只有参考价值,请勿以此为依据进行股票交易!

本站所有公式全部免费,如果这条公式对您有价值,或有帮助,请打开微信,扫一扫下面的二维码,赞助本站,金额随意!

感谢您对支持我们的发展和对我们工作的肯定!小编在些表示感谢!

本站提供通达信选股公式,看盘主图副图指标,编写,修改,DLL加密等业务,详询客服!